部分交换机配置

一、HUAWEI S3526

1.透传VLAN及开通专线业务案例:

<ZXJ_S3526_3>sys     //切换为特权模式
[ZXJ_S3526_3]display current-configuration interface ethernet 0/2     //查看千兆口0/2的状态
#
interface Ethernet0/2
shutdown     //该端口为关闭状态
#
return
[ZXJ_S3526_3]display vlan 506     //查看Vlan名为506的配置详情
VLAN ID: 506
VLAN Type: static
ARP proxy disabled.
Route Interface: not configured
Description: VLAN 0506
Name: VLAN 0506
Tagged   Ports:
GigabitEthernet3/1     //上行吉比特口3槽1口
Untagged Ports:
Ethernet0/1     //下行千兆口0槽1口
[ZXJ_S3526_3]interface GigabitEthernet 3/1     //进入吉比特口3/1
port  hybrid vlan 642 tagged     //把该端口包在vlan 642之内
[ZXJ_S3526_3]quit
[ZXJ_S3526_3]display current-configuration interface ethernet 0/1     //查看下行吉比特口0/1
#
interface Ethernet0/1
description xxxx     //端口描述详情
port access vlan 506     //端口vlan为506
traffic-limit inbound link-group 4000 rule 0 10     //当前端口流入速率为10M
line-rate 10     //当前端口速率为10M
#
return
[ZXJ_S3526_3]interface Ethernet 0/2     //进入千兆口0/2
[ZXJ_S3526_3-Ethernet0/2]undo shutdown     //打开该端口
[ZXJ_S3526_3-Ethernet0/2]description abcde     //添加端口描述为“abcd”
[ZXJ_S3526_3-Ethernet0/2]port  access vlan 642     //把该端口包在名为642的vlan中
[ZXJ_S3526_3-Ethernet0/2]traffic-limit inbound link-group 4000 rule 0 10     //限制该端口的流入速率为 10M
[ZXJ_S3526_3-Ethernet0/2]line-rate 10     //限制端口速率为10M
[ZXJ_S3526_3-Ethernet0/2]quit
[ZXJ_S3526_3]quit
<ZXJ_S3526_3>save     //保存配置到Flash
This will save the configuration in the flash memory.
The switch configurations will be written to flash.
Are you sure?[Y/N]y
Now saving current configuration to flash memory.
Please wait for a while...

二、Ericsson SE1200

1.专线配置案例:

SXCZ-PS-SE1200-B1
WARNING !!!  Authorised access only, all of your done will be recorded!

Disconnect IMMEDIATELY if you are not an authorised user!
login: ×××××
Password:
[local]SXCZ-PS-SE1200-B1#config     //进入全局模式
Enter configuration commands, one per line, 'end' to exit
[local]SXCZ-PS-SE1200-B1(config)#context local     //进入content实例:local如果已经创建了名为zhuanxian-1的接口,里面包含大段连续的IP地址,则无需另行创建。如果是30位或不在上述接口的IP,必须先创建一个接口
[local]SXCZ-PS-SE1200-B1(config-ctx)#interface abcde     //创建一个三层接口:abcde
[local]SXCZ-PS-SE1200-B1(config-if)#ip address 192.168.214.169/30     //设置该接口的ip地址为192.168.214.169,子网掩码为30位
[local]SXCZ-PS-SE1200-B1(config-if)#ip verify unicast source reachable-via rx     //源路径检测,rx表示只接受这个数据包的接口上对应的FIB中有该源地址所在的地址段;如果是any,则表示FIB表中无论哪个接口对应的地址,只要包括该源地址都可达,允许转发数据包
[local]SXCZ-PS-SE1200-B1(config-if)#ip access-group urpf in     //虚假源地址过滤
[local]SXCZ-PS-SE1200-B1(config-if)#commit     //保存配置
Transaction committed.
[local]SXCZ-PS-SE1200-B1(config-if)#exit
[local]SXCZ-PS-SE1200-B1(config-ctx)#exit    //以上步骤为30位IP操作,26位地址在建好IP Pool的情况下可以跳过上述步骤
[local]SXCZ-PS-SE1200-B1(config)#port ethernet 3/2     //进入千兆口3/2
[local]SXCZ-PS-SE1200-B1(config-port)#dot1q pvc 526     //创建互联PVC,Vlan为526
[local]SXCZ-PS-SE1200-B1(config-dot1q-pvc)#bind interface [abcde/zhuanxian-1] local     //将interface abcde或zhuanxian-1绑定到PVC
[local]SXCZ-PS-SE1200-B1(config-dot1q-pvc)#ip host 192.168.206.151     //为该PVC指定IP地址,30位的地址不需要添加此命令
[local]SXCZ-PS-SE1200-B1(config-dot1q-pvc)#commit
Transaction committed.
[local]SXCZ-PS-SE1200-B1(config-dot1q-pvc)#exit
[local]SXCZ-PS-SE1200-B1(config-port)#exit
[local]SXCZ-PS-SE1200-B1(config)#exit
[local]SXCZ-PS-SE1200-B1#save configuration     //保存配置
Save to file: redback.cfg
Target file exists, overwrite? y
[local]SXCZ-PS-SE1200-B1(config-ctx)#no interface abcde     //删除三层接口abced
[local]SXCZ-PS-SE1200-B1(config-port)#no dot1q pvc 526     //删除Vlan为526的PVC数据

2.新建IP Pool

[local]SXCZ-PS-SE1200-B1(config)#context local
[local]SXCZ-PS-SE1200-B1(config-ctx)#interface zhuanxian-1 multibind     //创建名为zhuanxian-1的IP Pool
ip address 192.168.204.65/26     //设置网关
ip verify unicast source reachable-via rx
ip arp proxy-arp     //启用代理ARP使用代理ARP的一个优点是,可以在网络中单独地增加一台路由器而不扰乱同在一个网络上的其他路由器的路由组成。使用代理ARP一个严重缺点是:会明显增加网络分段中的传输业务量,并且网络中的主机也将会保存比正常时大许多的ARP表。

3.开通FTTH/FTTB

宽带:

dot1q pvc 1160 encapsulation 1qtunnel
dot1q pvc on-demand 1160:1001 through 1800 encapsulation pppoe
idle-down 600
bind authentication pap maximum 1

IPTV:

dot1q pvc 3024 encapsulation 1qtunnel
dot1q pvc on-demand 3024:4057 encapsulation pppoe
idle-down 600
bind authentication pap maximum 500     //限制用户数

三、HUWEI ME60

1.专线配置案例:

[SXCZ-CZX-ME60-B1]interface GigabitEthernet2/1/0.500     //进入2/1/0的子接口500
[SXCZ-CZX-ME60-B1-GigabitEthernet2/1/0.500]user-vlan 623     //添加Vlan623
[SXCZ-CZX-ME60-B1-GigabitEthernet2/1/0.500-vlan-623-623]quit
[SXCZ-CZX-ME60-B1-GigabitEthernet2/1/0.500]quit
[SXCZ-CZX-ME60-B1]static-user 192.168.208.224 192.168.208.224 gateway 192.168.208.193 interface GigabitEthernet 2/1/0.500 vlan 623 domain-name zhuanxian detect     //配置静态路由,第一个192.168.208.224为起始IP地址,第二个192.168.208.224为终止IP地址(此条静态路由只有一个IP地址,所以起始和终止IP相同)。192.168.208.193为网关。     //以上是26位的IP地址做法,因为IP地址池zhuanxian已包含需要配置的IP
[SXCZ-XY-ME60-B1]interface GigabitEthernet3/1/0.630     //30位的地址或不在上述IP地址池的IP需要另行创建子接口
[SXCZ-XY-ME60-B1-GigabitEthernet3/1/0.630]vlan-type dot1q 630     //创建动态Vlan630
[SXCZ-XY-ME60-B1-GigabitEthernet3/1/0.630]description abcde     //添加描述
[SXCZ-XY-ME60-B1-GigabitEthernet3/1/0.630]ip address 192.168.223.17 255.255.255.252     //配置IP地址和子网掩码
[SXCZ-XY-ME60-B1-GigabitEthernet3/1/0.630]ip urpf loose     //URPF松散
[SXCZ-XY-ME60-B1-GigabitEthernet3/1/0.630]quit
[SXCZ-XY-ME60-B1]quit
<SXCZ-XY-ME60-B1>save
The current configuration will be written to the device.
Are you sure to continue?[Y/N]y
Now saving the current configuration to the slot 18 ..
Info: Save the configuration successfully.
Now saving the current configuration to the slot 17 .
Info: Save the configuration successfully.

2.新建IP Pool:

ip pool zhuanxian_1 bas local     //在local实例下创建名为zhuanxian_1的ip地址池
gateway 192.168.208.193 255.255.255.192     //设置该IP地址池的网关为192.168.208.193,26位的掩码
section 0 192.168.208.194 192.168.208.254     //设置起止IP分别为192.168.208.194和192.168.208.254
excluded-ip-address  192.168.208.194  192.168.208.254     //不用于动态分配的ip地址段为192.168.208.194~192.168.208.254
aaa     //进入Radius(远程接入计费认证)
accounting-scheme zhuanxian     //认证方式是zhuanxian
accounting-mode none      //认证模式无
quit
domain zhuanxian     //配置认证域
authentication-scheme zhuanxian
accounting-scheme zhuanxian
ip-pool zhuanxian_1

3.开通FTTH/FTTB

宽带:

interface GigabitEthernet2/0/1.201
pppoe-server bind Virtual-Template 1
user-vlan 1001 1500 qinq 1155 1156
user-vlan 1001 1024 qinq 1157
user-vlan 1001 1800 qinq 1213 1217
bas
#
access-type layer2-subscriber default-domain authentication cncchangzhi
option-82 parse-mode cn
access-limit 1 start-vlan 1001 end-vlan 1800 qinq 1213
access-limit 1 start-vlan 1001 end-vlan 1800 qinq 1214
access-limit 1 start-vlan 1001 end-vlan 1800 qinq 1215
access-limit 1 start-vlan 1001 end-vlan 1800 qinq 1216
access-limit 1 start-vlan 1001 end-vlan 1800 qinq 1217

四、ZTE 8912

1.透传VLAN:

SXCZ-QX-ZX8912-T1(config)#show vlan id 587     //查看VLAN 687
VLAN Name                                  PvidPorts   UntagPorts  TagPorts
--------------------------------------------------------------------------------
587  VLAN0587                                                      gei_11/17,ge i_12/41
SXCZ-QX-ZX8912-T1(config)#interface gei_11/17     //进入11槽17口
SXCZ-QX-ZX8912-T1(config-gei_11/17)#switchport hybrid vlan 579 tagged     //添加VLAN 579
SXCZ-QX-ZX8912-T1(config-gei_11/17)#exit
SXCZ-QX-ZX8912-T1(config)#interface gei_12/17     //进入12槽17口
SXCZ-QX-ZX8912-T1(config-gei_12/17)switchport trunk vlan 579     //添加VLAN 579
SXCZ-QX-ZX8912-T1(config)#exit
SXCZ-QX-ZX8912-T1#write     //保存配置

2.端口聚合:

先创建聚合:

interface smartgroup3     //创建一个名为smartgroup3的聚合
out_index 113     //系统自动生成
description TO-WH_C300     //添加描述
switchport mode hybrid     //端口模式为混合模式
switchport hybrid native vlan 4000     //本征Vlan(缺省Vlan)为4000
switchport hybrid vlan 50 tag     //以下Vlan要与需要做聚合的端口下一模一样
switchport hybrid vlan 1606-1607 tag
switchport hybrid vlan 1622 tag
switchport hybrid vlan 1646 tag
switchport hybrid vlan 1663 tag
switchport hybrid vlan 1690-1698 tag
switchport hybrid vlan 1985 tag
switchport hybrid vlan 3042 tag
smartgroup mode on     //开启动态模式

把端口加入聚合内(前提是该端口下配置的Vlan和聚合smartgroup 3下相同才能配进去,包括本征Vlan):

smartgroup 3 mode on

四、HUAWEI 5200G

1.专线配置案例:

[SXCZ-209-MA5200G-B1]interface GigabitEthernet 3/0/1.588     /*以下是30位IP的做法,30位的专线单独建立以VLAN号为名称的子接口*/
[SXCZ-209-MA5200G-B1-GigabitEthernet3/0/1.588]vlan-type dot1q vid 588     //添加VLAN588
[SXCZ-209-MA5200G-B1-GigabitEthernet3/0/1.588]description jiangsuhanhuanganzhuang     //添加描述
[SXCZ-209-MA5200G-B1-GigabitEthernet3/0/1.588]undo shutdown
[SXCZ-209-MA5200G-B1-GigabitEthernet3/0/1.588]ip address 60.220.245.97 255.255.255.252     //配置网关和掩码
[SXCZ-209-MA5200G-B1-GigabitEthernet3/0/1.588]traffic-policy guolv     /*30位IP的做法截止*/
[SXCZ-208-MA5200G-B1]interface GigabitEthernet 3/0/1.500     /*26位地址的做法,26位的专线都包含在500子接口下,便于管理*/
[SXCZ-208-MA5200G-B1-GigabitEthernet3/0/1.500]user-vlan 559     //添加VLAN559
[SXCZ-208-MA5200G-B1-GigabitEthernet3/0/1.500]quit
[SXCZ-208-MA5200G-B1]static-user 192.168.220.155 192.168.220.155 interface GigabitEthernet3/0/1.500 vlan 559 detect domain-name zhuanxian     //添加静态路由,第一个IP为起始IP,第二个IP为终止IP

2.开通FTTH/FTTB

宽带:

interface GigabitEthernet3/0/1.1120
qinq-vlan 1120
user-vlan 1001 1800
pppoe-server bind virtual-template 1
undo shutdown
bas
access-type layer2-subscriber default-domain authentication cncchangzhi
access-limit 1

IPTV:

interface GigabitEthernet6/0/1.3029
qinq-vlan 3029
user-vlan 4057
pppoe-server bind virtual-template 1
undo shutdown
igmp enable
multicast copy by-session
bas
access-type layer2-subscriber default-domain authentication cncchangzhi
access-limit 500

五、ZTE 6808

1.透传VLAN

interface vlan abc 604     //创建名为abc的VLAN,VLAN ID为604
add port 1/1 tagged     //添加端口1/1的标记
add port 2/10 tagged     //添加端口2/10的标记

六、HUAWEI S9303

1.端口聚合:

手动静态聚合:

先创建聚合:

[S9303]interface Eth-Trunk1     //创建端口聚合Eth-Trunk1
[S9303-Eth-Trunk1]description TO-QY_S9312     //添加描述
[S9303-Eth-Trunk1]undo port hybrid vlan 1     //去掉Vlan 1的透传
[S9303-Eth-Trunk1]port hybrid tagged vlan 50 to 52 70 526 554 to 555 901 904 1008 1023 1377 1382 to 1384
[S9303-Eth-Trunk1]port hybrid tagged vlan 1390 1392 1603 to 1604 1618 1622 to 1623 1636 1645 1662 to 1663 1668 1981
[S9303-Eth-Trunk1]port hybrid tagged vlan 1991 1999 3007 3023

把要聚合的端口下Vlan清空,配置成类似以下格式,这样两个口就加到了聚合里,注意把先要添加的端口(1/0/4)的上行端口(1/0/18)关闭以后再配置新端口(1/0/4)以免中断业务,然后打开新口的上行端口(1/0/18),再关闭旧端口(1/0/1)的上行端口(1/0/40),最后把旧端口(1/0/1)加到聚合里,确认无误后上下都做好聚合以后再把端口(1/0/40)打开

interface GigabitEthernet1/0/0
description TO_S9312-GE
eth-trunk 1
undo negotiation auto
#
return
[QY-BY-S9303]dis cur interface GigabitEthernet 1/0/4
#
interface GigabitEthernet1/0/4
description TO_S9312-GE_1/0/18
eth-trunk 1
undo negotiation auto

七、HUAWEI S9312

1.端口聚合:

手动静态聚合:

先创建聚合:

[S9312]interface Eth-Trunk1     //创建端口聚合Eth-Trunk1
[S9312-Eth-Trunk1]description TO-BY_S9303     //添加描述
[S9312-Eth-Trunk1]port hybrid pvid vlan 4000     //本征Vlan(缺省Vlan)为4000
[S9312-Eth-Trunk1]undo port hybrid vlan 1     //去掉Vlan 1的透传
[S9312-Eth-Trunk1]port hybrid tagged vlan 50 to 52 70 526 554 to 555 901 904 1008 1023 1377 1382 to 1384
[S9312-Eth-Trunk1]port hybrid tagged vlan 1390 1392 1603 to 1604 1618 1622 to 1623 1636 1645 1662 to 1663 1668 1981
[S9312-Eth-Trunk1]port hybrid tagged vlan 1991 1999 3007 3023

把要聚合的端口下Vlan清空,配置成类似以下格式,这样两个口就加到了聚合里,注意把先要添加的端口(1/0/18)的下行端口(1/0/4)关闭以后再配置新端口(1/0/18)以免中断业务,然后打开新口的下行端口(1/0/4),最后把旧端口(1/0/40)加到聚合里,确认无误后上下都做好聚合以后再把所有端口打开

interface GigabitEthernet1/0/18
undo negotiation auto
description TO-BY_9303_1/0/4
eth-trunk 1

LACP静态聚合:

interface Eth-Trunk3
port hybrid pvid vlan 4000
undo port hybrid vlan 1
port hybrid tagged vlan 51 to 52 70 303 528 903 1008 1061 1083 to 1085 1105 1122 to 1124
port hybrid tagged vlan 1260 1412 1416 1422 1630 to 1634 1800 to 1801 1998
port hybrid untagged vlan 4000
mode lacp-static     //启用LACP模式

把聚合的端口下配置成类似于下面这样:

interface GigabitEthernet1/0/13
undo negotiation auto
description TO-ZD_S6503-GE_2/0/8
eth-trunk 3

2.AG开局:

undo negotiation auto
description Yufengyuan-AG5200
port hybrid tagged vlan 55 1998
port hybrid untagged vlan 1357 4000
port vlan-stacking vlan 1001 to 1096 stack-vlan 1357

八、HUAWEI S6503

1.端口聚合:

LACP静态聚合:

先创建聚合:

link-aggregation group 2 mode static     //配置为LACP STATIC模式

然后要聚合的端口下配置数据要一致(描述除外):

interface GigabitEthernet2/0/7
description TO_S9312-GE_1/0/14
duplex full
speed 1000
port link-type hybrid
port hybrid vlan 51 to 52 70 303 528 903 1008 1061 1083 to 1085 1105 1122 to 1124 tagged
port hybrid vlan 1260 1412 1416 1422 1630 to 1634 1800 to 1801 1998 tagged
port hybrid vlan 4000 untagged
undo port hybrid vlan 1
lacp enable     //启用LACP
port link-aggregation group 2     //加入聚合组2中

九、HUAWEI S7802

1.端口聚合:

手动静态聚合:

先创建聚合:

link-aggregation group 1 mode manual     //配置为Manual模式

然后要聚合的端口下配置数据要一致(描述除外):

interface GigabitEthernet2/0/1
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 51 to 52 70 303 586 592 902 to 903 1003 1108 1111 to 1112 1199 tagged
port hybrid vlan 1235 1274 1339 1400 1548 1589 1601 1624 to 1625 1637 1989 tagged
port hybrid vlan 1997 1999 3008 tagged
port hybrid vlan 4000 untagged
speed 1000
duplex full
description TO_S9312-GE_2/0/1
port link-aggregation group 1     //加入聚合组1中

0 Likes
你目前的身份是游客,评论请输入昵称和电邮!

CAPTCHA